CentOS 7编译安装PHP 7.4提示No package 'libzip' found或者(libzip >= 0.11)

编译安装PHP 7.4提示No package 'libzip' found或者(libzip >= 0.11),原因是libzip没有安装或者版本太低,解决方法如下:


#卸载老版本的libzip

yum remove libzip

#下载安装libzip-1.2.0

wget https://libzip.org/download/libzip-1.2.0.tar.gz

tar -zxvf libzip-1.2.0.tar.gz

cd libzip-1.2.0

./configure

make && make install

安装完成后,查看是否存在/usr/local/lib/pkgconfig目录,如果存在,执行如下命令来设置PKG_CONFIG_PATH:


export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig/"