CentOS7 升级pip2遇到的坑

问题原因:
Python 2.7已于2020年1月1日到期,请停止使用。请升级您的Python,因为不再维护Python 2.7。pip 21.0将于2021年1月停止对Python 2.7的支持。pip 21.0将删除对此功能的支持。解决此问题并继续使用不受支持的Python 2.7,不应升级到最新的pip版本,而应升级到<21的版本。
相关文档: https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Python 2 Support
pip 20.3 was the last version of pip that supported Python 2. Bugs reported with pip which only occur on Python 2.7 will likely be closed as “won’t fix” issues by pip’s maintainers.

解决方法:
卸载python-pip后重新安装,升级时用以下指令:
pip install --upgrade "pip < 21.0" 

pip list 查看已安装的模块,看看pip版本

分享到:

如果您觉得上面的内容对您有帮助,可以打赏支持一下!

打赏

关键词:Linux

网友留言(0 条)

发表评论